FreeHost.com.UA
Апреля 22, 2018, 10:02:14 am *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.

Войти
Новости: Распродажа серверов http://freehost.com.ua/forum/index.php?topic=2093.0
 
   Начало   Помощь Поиск Войти Регистрация  
Страниц: [1]
  Печать  
Автор Тема: Postfix: lost connection after EHLO  (Прочитано 2821 раз)
мережевий хробачок™
Sr. Member
****

Karma: 3
Сообщений: 309



Просмотр профиля
« : Января 19, 2012, 01:04:06 am »

Сомневаюсь, что кто-то ответит - но рискну запостить и сюда :-)

Система: Postfix + Dovecot + MySQL | FreeBSD 8.2

Сервер только что настроен (ну, точнее аж вчера).
Отправка через Roundcube работает отличненько.
При попытке отправить через почтовый клиент - клиент выдает "Сервер отправил некорректное приветствие" (Thunderbrd). В логах сервера записывается следующее:

Код:
Jan 18 10:37:22 akira postfix/smtpd[5465]: lost connection after EHLO from pageant.charades.volia.net[93.74.55.57]
Jan 18 10:37:22 akira postfix/smtpd[5465]: disconnect from pageant.charades.volia.net[93.74.55.57]

В этом же почтовом клиенте есть ещё куча ящиков на других серверах - там отправка работает без проблем.
Гуглить уже немного устал. Как-то ничего толкового на эту тему не нашел.
Подскажите где искать решение проблемы?
З.Ы. конфиг Postfix-a пока выложил тут:
http://rtfm.co.ua/uploads/main.txt
Хотя - я не очень уверен что проблема именно в нем.

Для теста поставил ещё и TheBAT, аутентификация SMTP такая же как для РОР, он в свой лог пишет:

Код:
18.01.2012, 13:03:08: FETCH - Аутентификация прошла успешно (Обычный метод)
18.01.2012, 13:03:08: SEND  - Отправка почты - писем в очереди: 1
18.01.2012, 13:03:09: FETCH - Соединение завершено - получено писем: 0
!18.01.2012, 13:03:09: SEND  - Сервер сообщает, что он не готов, ответ: "421 "
18.01.2012, 13:03:09: SEND  - Соединение завершено - отправлено писем: 0
Записан
AMBA
Hero Member
*****

Karma: 2
Сообщений: 955



Просмотр профиля E-mail
« Ответ #1 : Января 19, 2012, 03:03:29 pm »

А напрямую письма отправляет, через телнет там например?

Такое нагуглил?

Цитировать
>>This smells like a classic MTU problem. Try to decrease MTU size on your
>>outgoing network interface.
> Thanks for your suggestion.
>
> I lowered MTU on Postfix Box to 1450...
>
> Still timing out on the body..
Try 1000.

Записан
мережевий хробачок™
Sr. Member
****

Karma: 3
Сообщений: 309



Просмотр профиля
« Ответ #2 : Января 19, 2012, 05:01:37 pm »

А напрямую письма отправляет, через телнет там например?

Такое нагуглил?

Цитировать
>>This smells like a classic MTU problem. Try to decrease MTU size on your
>>outgoing network interface.
> Thanks for your suggestion.
>
> I lowered MTU on Postfix Box to 1450...
>
> Still timing out on the body..
Try 1000.

Ага, напрямую отправляет. И через Roundcube отправляет. А через клиент - не хочет.
А проблему подсказали в ЖЖ http://ru-freebsd.livejournal.com/- антивирус вырубить :-)
Не знаю, что ему не нравилось - в этом почтовом клиенте шту 10 ящиков, все работают. А вот тут авасту что-то не понравилось.
как обычно - решение проблемы оказалось очень простым. А я совсем не в том направлении копал :-).
Записан
Страниц: [1]
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.16 | SMF © 2006-2011, Simple Machines Valid XHTML 1.0! Valid CSS!